VPS参考测评推荐专注分享VPS主机优惠信息
广告位联系QQ:6591303

网站首页 技术文档 正文

宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

云主机 2021-07-10 技术文档 26 ℃ 0 评论

不知道有没有同学碰到,数据库错误:Warning in ./libraries/plugin_interface.lib....,大鸟今天到是碰到了。找了原因发现是phpmyadmin版本不兼容当前使用的php版本导致的。

大鸟的服务器环境是,宝塔面板6.7,  php7.2 、mysql 5.5.57,nginx-1.14.1。这个问题解决起来也比较容易,升级phpmyadmin的版本即可。

phpmyadmin与PHP匹配说明:如果只有PHP5.2,请安装 phpmyadmin4.1。如果只有PHP5.5及以下版本,请安装phpmyadmin4.4。如果只有PHP7.x,请安装phpmyadmin4.7/4.8版本!大鸟这里用的是phpmyadmin4.4的版本,所以出现了这个错误。

用宝塔面板安装phpmyadmin 还是很方便的。

第一,卸载旧版本

到后台软件管理中,卸载phpmyadmin4.4!

第二、安装新版本

额,没啥好说的,这样之后就可以了。

第三、总结

重新安装下phpmyadmin版本,php7.2的需要phpmyadmin4.7/4.8版本的即可,或者我们换个低版本的php也可以。

解决方法总结:

在软件管理 - phpmyadmin - 设置 - PHP版本

然后选择其它PHP版本即可。

phpmyadmin与PHP匹配说明:

如果只有PHP5.2,请安装 phpmyadmin4.1

如果只有PHP5.5及以下版本,请安装phpmyadmin4.4

如果只有PHP7.x,请安装phpmyadmin4.7/4.8版本!

请在这里放置你的在线分享代码

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

最近发表
最新留言
    网站分类
    标签列表