VPS参考测评推荐专注分享VPS主机优惠信息
广告位联系QQ:6591303

网站首页 技术文档 正文

宝塔面板设置python3的一些技巧分享 -基于centos7环境

云主机 2021-07-10 技术文档 8 ℃ 0 评论

宝塔面板的默认python版本是2.7.5,不过目前最新版本的宝塔面板是支持python3的,但是你要把这货找出来也挺麻烦,这篇文章就来整理分享一些宝塔面板如何设置默认的python版本为3.7。

宝塔服务器面板,一键全能部署及管理,送你3188元礼包,点我领取https://www.bt.cn/?invite_code=MV9ub2NxdmI=

1、前言

本文的讲述基于centos7,默认安装的宝塔版本是实验性的基于py3.7版本的宝塔。实验性版本的宝塔安装脚本。

curl -sSO http://download.bt.cn/install/install_panel.sh && bash install_panel.sh

2、方法1

基于以上宝塔安装的脚步,如果你要使用py3.7,可以使用btpython

[root@racknerd-bdbe19 ~]# btpython -V
Python 3.7.9

我们看到这样就可以查到py的默认版本为3.7.9,如果你要执行python脚本,就需要btpython后面加上脚本的方法了,如下。

btpython test.py

注意,这个时候默认的你输入python -V来查询还是2.7.5,你需要加上btpython才可以切换到python3.7.9版本。

3、方法2

安装 Python3,就是自己去安装一个python3,替代默认的2.7.5,这个方法适合普通脚本安装宝塔的童鞋。

1)ubuntu、debian可以用这个命令

apt install python3-pip

2)centos7可以用如下命令

yum -y install python3-pip

3)安装好后,输入一下代码查询版本。

[root@racknerd-bdbe19 ~]# python3 -V
Python 3.6.8

4)使用,你需要这样使用。

python3 test.py

4、方法3

将默认的python2改为python3,首选安装方法2安装好python3,之后看如下的教程。

注意,删除前请先备份下你的python2.7.5,备份命令如下:

cp /usr/bin/python /usr/bin/python_bak

1)要想使用python -V就是3版本的话,你需要这样做。删除python快捷方式,重新绑定python3到python即可,命令如下:

[root@VM-4-15-centos ~]# which python  #查询py版本路径
/usr/bin/python
[root@VM-4-15-centos ~]# rm /usr/bin/python  #删除默认的软连接
rm: remove symbolic link ‘/usr/bin/python’? y  #输入y确认删除
[root@VM-4-15-centos ~]# ln -s /usr/bin/python3 /usr/bin/python  #用新的版本代替默认
[root@VM-4-15-centos ~]# python -V  #再次查询
Python 3.6.8

2)还有默认的包管理器pip也更改为pip3,这一步可选。

 rm /usr/bin/pip
ln -s /usr/bin/pip3 /usr/bin/pip

具体的执行命令如下:

[root@VM-4-15-centos ~]# rm /usr/bin/pip
rm: remove symbolic link ‘/usr/bin/pip’? y
[root@VM-4-15-centos ~]# ln -s /usr/bin/pip3 /usr/bin/pip
[root@VM-4-15-centos ~]# pip3 -V
pip 9.0.3 from /usr/lib/python3.6/site-packages (python 3.6)
[root@VM-4-15-centos ~]#

5、方法5

1)如果是centos7安装的宝塔,我们还可以利用宝塔的python管理器来指定默认的py版本,看教程。

宝塔面板python管理器安装python各版本,并设置python3为默认环境

2)缺点,退出shell,python版本就会失效回到2.7.5的状态。

6、一些坑

1)方法3修改默认的python到python3之后,Centos yum命令无法使用。,错误提示如下:

[root@VM-4-15-centos ~]# yum -y update
File "/usr/bin/yum", line 30
except KeyboardInterrupt, e:
^
SyntaxError: invalid syntax

2)这是因为yum默认使用python2版本,所以我们要更改yum的python代码为python2:

vi $(which yum)

3)用vi编辑器将第一行改为python2然后退出保存即可,看图:

7、改回python2

这里是方法3的逆向。改回到python2.7.5,这里提供2个方法。

文章加密,密码获取,可加tg获取。

tg订阅:https://t.me/rssbig

tg群:https://t.me/joinchat/SKct5jFnL_PUvCFr

进入tg群后,输入:改回python2 ,会自动跳出密码。

输入密码查看隐藏内容:

8、最后

终于能结束了,教程有点乱,以后可能还会变化,暂时先这样,教程仅供参考!!!

请在这里放置你的在线分享代码

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

最近发表
最新留言
    网站分类
    标签列表